Garage ShoutBox
Tylko zalogowani użytkownicy mogą wejść do czatu
lub Zarejestruj aby założyć posty i tematy.

Ender 3 + 4.2.7MB + Hallon v3 - problem

Cześć,

Na dniach zakupiłem Ender'a 3, płytkę 4.2.7, czujnik Hallon v3 oraz parę innych gratów.

Ender 3 wyposażony był w płytę 4.2.2, którą podmieniłem na 4.2.7. Oryginalny ekstruder podmieniłem na Bondtech BMG. Ekstruder po zamianie pinów 1-4 i ustawieniu "e-steps" z 93 na 411 działał perfekcyjnie. Następnie przyszło do poziomowania stołu. Oryginalne sprężyny podmieniłem na te znane żółte, z tą różnicą, że oryginalne miały długość 20mm, nowe mają 25mm. Wypoziomowałem stół najlepiej jak umiem.  Przy narożnikach dysza schodzi na 0.14mm natomiast środek stołu jest wklęsły (nożyk 0.5mm wchodzi bez problemu między stół a dyszę). Z tego powodu nawet nie puszczam pierwszego druku, bo wiem, że wyjdzie badziew.

Zamontowałem czujnik Hallon, pobrałem najnowszego Marlina, wprowadziłem zmiany w pliku "configuration.h", kompilacja udała się. Firmware wgrał się bez problemu.

Podpiąłem kompa z drukarką, odpaliłem Hallon Configuration 2 i przy naciśnięciu "odśwież port" nic się nie zmieniło. Widnieje pusta przestrzeń. Naciśnięcie "połącz" skutkowało wyłączeniem się konfiguratora.

Pobrałem Zadig, pobrałem sterownik, który w Zadigu widnieje jako "WinUSB (v6. 1.7600.16385). Sterownik zainstalował się pomyślnie, jednak w Konfiguratorze po odświeżeniu portów, dalej nic się nie pojawiło. Następnie, dzięki wpisom @Kosiara pobrałem "USB-Serial CH340". Instalacja kończy się komunikatem "Driver install failure".

Proszę o jakieś pomysły co mogę zrobić by uruchomić Hallon'a.

Z tak wklęsłym na środku stołem nawet nie zabieram się za drukowanie.

Drukarkę łączyłem dwoma różnymi przewodami, żeby wyeliminować problem z wadliwym "kablem".

Kamilu postaram się pomóc wieczorem, mamy tygodniowe przesunięcie z powodu wymiany dachu na warsztacie. Opanujemy temat.

Dzięki za odpowiedź.

Zainstalowałem rano Configuratora 3 i ten bez problemu znalazł port.

Naciśnięcie "Home" zbazowało mi ładnie oś X oraz Y. Przy bazowaniu Zeta maszynka pojechała sobie do góry, co mnie trochę zdziwiło.

Następnie (tak jak na filmiku) odblokowałem oś Z, dojechałem na trochę ponad dyszkę nad stół, kliknąłem "ustaw offset" i maszynka pojechała sobie w górę z około 60, czy 80mm i ustawiła "Zeta" na tej wysokości.

Przy kolejnej próbie bazowania wystąpił podobny problem. Przy następnej - ten sam. Z tym, że za każdym razem baza osi Z ustawiana była 15mm wyżej.

Ostatecznie - odpuściłem sobie mapowanie stołu, odpiąłem czujnik, podpiąłem krańcówkę osi Z, pobawiłem się trochę w ręczne poziomowanie stołu i tak - na narożnikach jestem ciutek ponad dychę w +, na środku stołu 35-40 setek w +.

Pierwsze druki na Enderze już za mną. Drobnicę odsuwam od środka stołu do krawędzi, większe elementy centruję i jak na razie jestem zadowolony z efektów.

Możliwe, że coś pochrzaniłem w Marlinowskim "configuration.h", bo nadmienię, że jeśli chodzi o programowanie w jakiś C++, C#, czy innych takich komputerowych, to noga jestem.

Wpadł mi też do głowy pomysł, żeby pobrać przykładowy g-code na mapę i z palca go "przerobić" ustalając "Zety" od szczelinomierza, czy od płytek wzorcowych.

Jeszcze raz - dzięki za odzew. W załączniku wrzucam plik "configuration.h"

Plik "configuration_adv.h" w najnowszym Marlinie jest niemalże taki sam dla płytki 4.2.2 i 4.2.7.

Dodane pliki:
  • Aby przesyłać pliki musisz się zalogować.

Witam

zakupilem hallon3 jakies 2 miesiace temu (z braku czasu nie instalowalem czujnika), i mam podobny problem, po ustawieniu offsetu (i po home) drukarka w osi z ustawia sie za kazdym razem dodajac wartosci w gore, nie ustawia sie do pozycji "0" w osi z (4.2.2), kompilacja marlina pobrana z waszej strony